Skip to main content
NetApp Stage KB

Failed to deploy connector. Request failed with status code 400

Applies to

  • Cloud Manager
  • Microsoft Azure

Issue

New Azure connector deployment is failing with a 400 error in the connector wizard:
 
{"message":"Failed to deploy connector.","priority":"error"}
{"message":"Request failed with status code 400","priority":"error"}
{"error":{"code":"InvalidTemplateDeployment","message":"The template deployment failed because of policy violation. Please see details for more information.","details":[{"code":"RequestDisallowedByPolicy","target":"the-target","message":"Resource 'the-resource' was disallowed by policy. Policy identifiers: '[{\"policyAssignment\":{\"name\":\"[MAPS Hub&Spokes] Ensure https traffic only for storage account\",\"id\":\"/providers/Microsoft.Management/managementGroups/xx-

Sign in to view the entire content of this KB article.

New to NetApp?

Learn more about our award-winning Support

NetApp provides no representations or warranties regarding the accuracy or reliability or serviceability of any information or recommendations provided in this publication or with respect to any results that may be obtained by the use of the information or observance of any recommendations provided herein. The information in this document is distributed AS IS and the use of this information or the implementation of any recommendations or techniques herein is a customer's responsibility and depends on the customer's ability to evaluate and integrate them into the customer's operational environment. This document and the information contained herein may be used solely in connection with the NetApp products discussed in this document.
d3dcf5a2-8b3b-49ea-a0f4-9030de6953f7